circumstellar 0.1.51

  • Installing
  • Versions
  • 0

Circumstellar logo
Travis Pub

A Dart wrapper for the Discord API. Feel free to contribute!

Documentation is available here, and examples can be found in the example directory.

Features #

  • Speedy (built upon the latest versions of the Dart SDK and web APIs)
  • Small dependency tree (only one direct dependency - w_transport, for both WebSocket and REST // five development dependencies)
  • Predictable - robust and well-defined type checks included with all models
  • Multiplatform - runs anywhere Dart VM (Web support soon) does

Example #

A quick example of the client in action:

import 'package:circumstellar/circumstellar.dart';

import 'package:w_transport/vm.dart' show vmTransportPlatform;
// Dart for Web: import 'package:w_transport/browser.dart' show browserTransportPlatform;

void main() {
  var client = new DiscordClient(new AuthSet('MY_TOKEN', TokenType.Bot), vmTransportPlatform /* dart for web: browserTransportPlatform */);
  client.dispatcher.messageCreate.listen((Message msg) async {
    print('Received message with ID ${} (Channel ID ${})');
    print('Content: ${msg.content}');
    if (msg.content == '!ping') {
  client.dispatcher.ready.listen((empty) {

Contributing #

Contributing guidelines:

  • Please use dartfmt and follow Dart's standard formatting rules for all your contributions
  • Please follow the naming conventions already laid out in the project
  • The tests haven't been fully written yet, so you can run bin/dev.dart (check file for the environment variables to set) to run a dev instance/test client of Circumstellar. You can also use the Shell script

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.1.20-dev #

  • Add logging system
  • Remove TObjectId type parameter from internal entities

0.1.12 #

  • Jump releases for Pub publishing

0.1.2 #

  • Added Guild object
    • Added guildUpdate and guildCreate events
  • Added caching system for most Discord objects
  • Added image CDN endpoints for User and Guild

0.1.11 #

  • Fixed docs

0.1.1 #

  • Added caching for channels
  • Added channelCreate and channelUpdate events
  • Refactor entity system
  • Fix REST requests

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  circumstellar: ^0.1.51

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:circumstellar/circumstellar.dart';
Version Uploaded Documentation Archive
0.1.51 Jun 22, 2018 Go to the documentation of circumstellar 0.1.51 Download circumstellar 0.1.51 archive
0.1.22 Jun 22, 2018 Go to the documentation of circumstellar 0.1.22 Download circumstellar 0.1.22 archive
0.1.12 Jun 20, 2018 Go to the documentation of circumstellar 0.1.12 Download circumstellar 0.1.12 archive
0.1.11 Jun 20, 2018 Go to the documentation of circumstellar 0.1.11 Download circumstellar 0.1.11 archive
0.1.2 Jun 20, 2018 Go to the documentation of circumstellar 0.1.2 Download circumstellar 0.1.2 archive
0.1.1 Jun 20, 2018 Go to the documentation of circumstellar 0.1.1 Download circumstellar 0.1.1 archive
0.1.0 Jun 19, 2018 Go to the documentation of circumstellar 0.1.0 Download circumstellar 0.1.0 archive
0.1.20-dev1 Jun 20, 2018 Go to the documentation of circumstellar 0.1.20-dev1 Download circumstellar 0.1.20-dev1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.40.0 <=3.0.0