circulardropdownmenu 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 74

CircularDropDownMenu #

Description #

A custom dropdown button lets the user select from a number of items. The button shows the currently selected item as well as an arrow that opens a menu for selecting another item. A new Flutter package created by suryadevsingh.

Demo #

Contributing #

Pull requests are welcome. For major changes, please open an issue first to discuss what you would like to change.

[0.0.1] - TODO: Add release date. #

[0.0.2] - Readme.md #

[0.0.3] - Readme.md (demo) #

[0.0.4] - Readme.md (description) #

[1.0.0] - Added --Example #

[1.0.1] - Added --License #

  • TODO: Describe initial release.

example/main.dart

import 'package:circulardropdownmenu/circulardropdownmenu.dart';
import 'package:flutter/material.dart';

void main() {
   runApp(MyApp());
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      debugShowCheckedModeBanner: false,
      home: DemoCircularDropDownMenu(),
    );
  }
}

class DemoCircularDropDownMenu extends StatefulWidget {
  @override
  _DemoCircularDropDownMenuState createState() => _DemoCircularDropDownMenuState();
}

class _DemoCircularDropDownMenuState extends State<DemoCircularDropDownMenu> {

  String _coachingLevel = 'Education Level';

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: SingleChildScrollView(
        child: Container(
          margin:
          EdgeInsets.only(left: 20, top: 40, right: 20, bottom: 20),
          child: Column(
            children: <Widget>[

              CircularDropDownMenu(
                dropDownMenuItem: [
                  DropdownMenuItem(
                    child: GestureDetector(
                      onTap: () {},
                      child: Text('School'),
                    ),
                    value: 'School',
                  ),
                  DropdownMenuItem(
                    child: GestureDetector(
                      onTap: () {},
                      child: Text('Collage'),
                    ),
                    value: 'Collage',
                  ),
                  DropdownMenuItem(
                    child: GestureDetector(
                      onTap: () {},
                      child: Text('Graduated'),
                    ),
                    value: 'Graduated',
                  ),
                ],
                onChanged: (value) {
                  setState(() {
                    _coachingLevel = value;
                  });
                },
                hintText: _coachingLevel,
              ),

            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  circulardropdownmenu: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:circulardropdownmenu/circulardropdownmenu.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • circulardropdownmenu that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test