charts_shamsi_common 1.0.1

  • Readme
  • Changelog
  • Installing
  • new58

Common Shamsi Charting library #

Common componnets for charting libraries but patched to be able to use shamsi date too.

1.0.1 #

  • show shamsi date if locale is 'fa'

1.0.0+6 #

  • bump

1.0.0+5 #

  • bump

1.0.0+4 #

  • bump

1.0.0+3 #

  • bump

1.0.0+2 #

  • bump

1.0.0+1 #

  • bump

1.0.0 #

  • init

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  charts_shamsi_common: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:charts_shamsi_common/charts_shamsi_common.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
20
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Analysis suggestions

Package not compatible with SDK dart

Because:

  • charts_shamsi_common that depends on:
  • shamsi_date that is a package requiring null.

Health suggestions

Fix lib/src/chart/treemap/treemap_label_decorator.dart. (-1 points)

Analysis of lib/src/chart/treemap/treemap_label_decorator.dart reported 2 hints:

line 121 col 16: Use = to separate a named parameter from its default value.

line 121 col 36: Use = to separate a named parameter from its default value.

Fix lib/src/chart/bar/bar_label_decorator.dart. (-0.50 points)

Analysis of lib/src/chart/bar/bar_label_decorator.dart reported 1 hint:

line 141 col 13: The value of the local variable 'outsideBarHeight' isn't used.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and charts_shamsi_common.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
collection ^1.14.5 1.14.12 1.14.13
intl >=0.15.2 <0.17.0 0.16.1
logging ^0.11.4 0.11.4
meta ^1.1.1 1.1.8 1.2.2
shamsi_date ^0.8.1 0.8.1
vector_math ^2.0.8 2.0.8 2.1.0-nullsafety
Transitive dependencies
flutter 0.0.0
path 1.7.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
Dev dependencies
mockito ^4.0.0
test ^1.5.3