charts_common_cf 0.10.3+cf

  • Readme
  • Changelog
  • Installing
  • 68

Common Charting library #

pub package

Common componnets for charting libraries.

Development #

This is from exafree/charts_cf, a fork of google/charts. Contributions are most welcome.

Changelog #

All notable changes to this project are documented by extracting information from git commits. This project adheres to Semantic Versioning.

0.10.3+cf - 2020-06-10 #

Direct Commits #

Merged Commits #

  • Add custom template for use by auto-changelog #30
  • Improve release process and add documentation #27
  • Add gen-changelog to Makefile #24
  • Update README.md #20
  • Fix CHANGELOGs I messed them up in the forking process #19
  • Fix some NaNs when window is small #15
  • Allow generating higher resulution ticks #14
  • Fix issues in getMinPixels and getMaxPixels #10

Issues Fixed #

  • #28: Add custom template for use by auto-changelog #30
  • #23: Add gen-changelog to Makefile #24
  • #16: Update README.md #20
  • #18: Fix CHANGELOGs I messed them up in the forking process #19
  • #8: Fix issues in getMinPixels and getMaxPixels #10

0.10.2 - 2020-05-24 #

Direct Commits #

  • Fork google/charts and create new packages e221a23
  • Try again, forgot to add homepage to sed script for pubspec.
  • Tweak link in charts_flutter_cf/README.md to github.com/exafree/charts_cf

0.10.1 #

  • Second attempt at a Fork of google/charts with pachages renamed from charts_common and charts_flutter to charts_common_cf and harts_flutter_cf. Where "cf" is an acronym for "community fork".

  • Fix the incorrect homepage links in the pubspec.yaml

  • In Makefile fixed a typo, leaving off the _cf in cd charts_common_cf in the publish_common target. And remove a debug ls in test_flutter target.

0.10.0 #

  • Fork of google/charts with pachages renamed from charts_common and charts_flutter to charts_common_cf and charts_flutter_cf. Where "cf" is an acronym for "community fork".

0.9.0 #

  • Internal bug fixes
  • Bump versions in Gemlock file due to security alerts

0.8.1 #

  • Update intl version.

0.8.0 #

  • Bug fixes from open source.

0.7.0 #

  • Added vertical bar label

0.6.0 #

  • Bars can now be rendered on line charts.
  • Negative measure values will now be rendered on bar charts as a separate stack from the positive values.
  • Added a Datum Legend, which displays one entry per value in the first series on the chart. This is useful for pie and scatter plot charts.
  • The AxisPosition enum in RTLSpec was refactored to AxisDirection to better reflect its effect on swapping the positions of all start and end components, and not just positioning the measure axes.
  • Added custom colors for line renderer area skirts and confidence intervals. A new "areaColorFn" has been added to Series, and corresponding data to the datum. We could not use the fillColorFn for these elements, because that color is already applied to the internal section of points on line charts (including highlighter behaviors).

0.5.0 #

  • SelectionModelConfig's listener parameter has been renamed to "changeListener". This is a breaking change. Please rename any existing uses of the "listener" parameter to "changeListener". This was named in order to add an additional listener "updateListener" that listens to any update requests, regardless if the selection model has changed.
  • CartesianChart's method getMeasureAxis(String axisId) has been changed to getMeasureAxis({String axisId) so that getting the primary measure axis will not need passing any id that does not match the secondary measure axis id. This affects users implementing custom behaviors using the existing method.

0.4.0 #

  • Declare compatibility with Dart 2.
  • BasicNumericTickFormatterSpec now takes in a callback instead of NumberFormat as the default constructor. Use named constructor withNumberFormat instead. This is a breaking change.
  • BarRendererConfig is no longer default of type String, please change current usage to BarRendererConfig
  • BarTargetLineRendererConfig is no longer default of type String, please change current usage to BarTargetLineRendererConfig

0.3.0 #

  • Simplified API by removing the requirement for specifying the datum type when creating a chart. For example, previously to construct a bar chart the syntax was 'new BarChart
  • Added scatter plot charts
  • Added tap to hide for legends
  • Added support for rendering area skirts to line charts
  • Added support for configurable fill colors to bar charts

0.2.0 #

  • Update color palette. Please use MaterialPalette instead of QuantumPalette.
  • Dart2 fixes

0.1.0 #

Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  charts_common_cf: ^0.10.3+cf

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:charts_common_cf/charts_common_cf.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Health suggestions

Fix lib/src/chart/treemap/treemap_label_decorator.dart. (-1 points)

Analysis of lib/src/chart/treemap/treemap_label_decorator.dart reported 2 hints:

line 121 col 16: Use = to separate a named parameter from its default value.

line 121 col 36: Use = to separate a named parameter from its default value.

Fix lib/src/chart/bar/bar_label_decorator.dart. (-0.50 points)

Analysis of lib/src/chart/bar/bar_label_decorator.dart reported 1 hint:

line 141 col 13: The value of the local variable 'outsideBarHeight' isn't used.

Format lib/src/chart/cartesian/axis/draw_strategy/base_tick_draw_strategy.dart.

Run dartfmt to format lib/src/chart/cartesian/axis/draw_strategy/base_tick_draw_strategy.dart.

Format lib/src/chart/cartesian/axis/numeric_tick_provider.dart.

Run dartfmt to format lib/src/chart/cartesian/axis/numeric_tick_provider.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and charts_common_cf.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
collection ^1.14.5 1.14.13
intl >=0.15.2 <0.17.0 0.16.1
logging ^0.11.4 0.11.4
meta ^1.1.1 1.1.8
vector_math ^2.0.8 2.0.8
Transitive dependencies
path 1.7.0
Dev dependencies
mockito ^4.0.0
test ^1.5.3