chamber 0.0.1

  • Readme
  • Changelog
  • Installing
  • 36

Chamber 🚪

Work in progress :construction_worker:

Object-Relational Mapper for Flutter

Roadmap: #

  • [x] Code generator
  • [x] Table creation
  • [x] Unique/Index/NotNull
  • [x] Insert/Update/Delete
  • [ ] Simple queries
  • [ ] Default
  • [ ] Unique together
  • [ ] Foreign Keys
  • [ ] Advanced queries

Not on roadmap, but interesting features: #

  • [ ] Custom type converters
  • [ ] Wrap optional columns with Optional
  • [ ] Migrations

Ideas: #

  • [ ] Observable queries
  • [ ] Rendering helpers that observe query changes

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  chamber: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:chamber/chamber.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
93
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

76 out of 76 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/database/impl.dart. (-1.49 points)

Analysis of lib/src/database/impl.dart reported 3 hints:

line 14 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 25 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 51 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/src/database/interface.dart. (-1.49 points)

Analysis of lib/src/database/interface.dart reported 3 hints:

line 5 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 6 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 7 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/chamber.dart. (-1 points)

Analysis of lib/chamber.dart reported 2 hints:

line 30 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 60 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/src/meta.dart. (-1 points)

Analysis of lib/src/meta.dart reported 2 hints:

line 34 col 17: Override hashCode if overriding ==.

line 36 col 15: Test type arguments in operator ==(Object other).

Fix lib/src/model.dart. (-1 points)

Analysis of lib/src/model.dart reported 2 hints:

line 6 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 8 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/caiopo/chamber was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and chamber.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
meta ^1.1.6 1.1.7
path ^1.6.2 1.6.4
pedantic ^1.4.0 1.8.0+1
sqflite ^1.0.0 1.1.7+1
Transitive dependencies
collection 1.14.11 1.14.12
sky_engine 0.0.99
synchronized 2.1.0+1
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.0.0