carousel_widget 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 79

carousel_widget #

A library for the use of the Carousel Widget through a list of Fragments

Getting Started #

Implements package in your pubspec.yaml

dependencies:
  flutter:
    sdk: flutter
  carousel_widget: 

Use the Carousel and the Fragment to implement any type of Widget

Example #

import 'package:flutter/material.dart';
import 'package:carousel_widget/carousel_widget.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Carousel Example',
      theme: ThemeData(
        // This is the theme of your application.
        //
        // Try running your application with "flutter run". You'll see the
        // application has a blue toolbar. Then, without quitting the app, try
        // changing the primarySwatch below to Colors.green and then invoke
        // "hot reload" (press "r" in the console where you ran "flutter run",
        // or simply save your changes to "hot reload" in a Flutter IDE).
        // Notice that the counter didn't reset back to zero; the application
        // is not restarted.
        primarySwatch: Colors.blue,
      ),
      home: MyCarousel(),
    );
  }
}

class MyCarousel extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Carousel(
        listViews: [
          Fragment(
            child: ListView.builder(
              itemCount: 24,
              itemBuilder: ((context, index) => ListTile(
                    title: Text('index $index'),
                  )),
            ),
          ),
          Fragment(
            child: CircleAvatar(
              radius: 56,
              backgroundColor: Colors.orange,
              child: Text(
                'LM',
                style: TextStyle(fontSize: 48),
              ),
            ),
          )
        ],
      ),
    );
  }
}

[0.0.1] Initial Release

  • Implementation of Carousel and Fragment as container of Widgets

[0.0.2] Config Structure

  • Change export library

[0.0.3] Config Structure

  • Change export library

[0.0.4] Beta

  • Export beta stable

[0.1.0] Release

  • Release

[0.1.1] Release Format

  • Release

example/README.md

carousel_widget #

A library for the use of the Carousel Widget through a list of Fragments

Getting Started #

Implements package in your pubspec.yaml

dependencies:
  flutter:
    sdk: flutter
  carousel_widget: ^ 0.1.1

Use the Carousel and the Fragment to implement any type of Widget

Example #

import 'package:flutter/material.dart';
import 'package:carousel_widget/carousel_widget.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Carousel Example',
      theme: ThemeData(
        // This is the theme of your application.
        //
        // Try running your application with "flutter run". You'll see the
        // application has a blue toolbar. Then, without quitting the app, try
        // changing the primarySwatch below to Colors.green and then invoke
        // "hot reload" (press "r" in the console where you ran "flutter run",
        // or simply save your changes to "hot reload" in a Flutter IDE).
        // Notice that the counter didn't reset back to zero; the application
        // is not restarted.
        primarySwatch: Colors.blue,
      ),
      home: MyCarousel(),
    );
  }
}

class MyCarousel extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Carousel(
        listViews: [
          Fragment(
            child: ListView.builder(
              itemCount: 24,
              itemBuilder: ((context, index) => ListTile(
                    title: Text('index $index'),
                  )),
            ),
          ),
          Fragment(
            child: CircleAvatar(
              radius: 56,
              backgroundColor: Colors.orange,
              child: Text(
                'LM',
                style: TextStyle(fontSize: 48),
              ),
            ),
          )
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  carousel_widget: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:carousel_widget/carousel_widget.dart';
  
Version Uploaded Documentation Archive
0.1.1 Feb 19, 2019 Go to the documentation of carousel_widget 0.1.1 Download carousel_widget 0.1.1 archive
0.1.0 Feb 18, 2019 Go to the documentation of carousel_widget 0.1.0 Download carousel_widget 0.1.0 archive
0.0.4 Feb 17, 2019 Go to the documentation of carousel_widget 0.0.4 Download carousel_widget 0.0.4 archive
0.0.3 Feb 16, 2019 Go to the documentation of carousel_widget 0.0.3 Download carousel_widget 0.0.3 archive
0.0.2 Feb 16, 2019 Go to the documentation of carousel_widget 0.0.2 Download carousel_widget 0.0.2 archive
0.0.1 Feb 16, 2019 Go to the documentation of carousel_widget 0.0.1 Download carousel_widget 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Jun 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test