carousel 0.1.0

  • Readme
  • Changelog
  • Installing
  • 42

Carousel #

A Flutter simple Carousel Widget.

Usage #

As simple as using any flutter Widget. The Carousel package hides all the complexity (almost none, it's Flutter!) of implementing a carousel.

Example: First things first, add the module to your project pubspec.yaml:

 carousel: ^0.0.1

And install it using flutter packages get on your project folder. After that, just import the module and use it:

import 'package:carousel/carousel.dart';

new SizedBox(
  height: 240.0,
  child: new Carousel(
    children: [
      new NetworkImage(''),
      new NetworkImage('')
    ].map((netImage) => new Image(image: netImage)).toList(),

This code snippet creates an Carousel with an height of 240.0 that contains both the logos of Flutter and React native, as an example. Simples as that! 😄

Credits #

Developed by Gabriel Valério

Contributing #

Feel free to help!

[0.0.1] - TODO: Add release date.

  • TODO: Simplest carousel implementation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  carousel: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:carousel/carousel.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.