camscan 1.0.7

camscan #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[1.0.7].

  • added permission request

[1.0.6].

  • changed the version of fast_qr_reader_view

[1.0.5].

  • corrected void .scan to Future.

[1.0.4].

  • .scan is now async method. Can be awaited for the camera to pop.

[1.0.3].

  • result handler will now accept buildcontext as argument

[1.0.2].

  • Changed some public methods to private

[1.0.1].

  • Added a new default decoder to accept any string

[1.0.0].

  • Everything is good now

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  camscan: ^1.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:camscan/camscan.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.06 points)

30 out of 31 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/camwidget.dart. (-0.50 points)

Analysis of lib/camwidget.dart reported 1 hint:

line 4 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: CamWidget.popOnSuccess, CamWidget.popOnFail, CamWidget.resultHandler, CamWidget.camDes, CamWidget.widgetTitle, CamWidget.currentContext

Format lib/DefaultDecoder/defaultDecoder.dart.

Run flutter format to format lib/DefaultDecoder/defaultDecoder.dart.

Format lib/camscan.dart.

Run flutter format to format lib/camscan.dart.

Maintenance issues and suggestions

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: fast_qr_reader_view.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and camscan.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
fast_qr_reader_view 0.1.6
flutter 0.0.0
permission_handler ^3.1.0 3.2.2
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test