calzone 0.4.0

calzone #

Use your Dart library from JavaScript!

A compiler/patcher for a JS bridge to your Dart library, using dart2js and analyzer.

Even though calzone.dart is reaching maturity, if you're interested in using it and are having problems using it, please contact mbullington on the Dart Slack.

Transformers #

A large part of calzone works by transformers. A transformer is an addon to the compiler that will bridge together a Dart type (or types) with their JavaScript equivalents. An example of this is the PromiseTransformer, where it will take Promises and convert them to Futures, and vice versa. This API is frozen and is available for projects using calzone to build their own.

The best example of this is in the calzone.transformers library, which is our standard library for transformers. Most of these transformers are suggested for use, such as Promises <-> Future, Closure, and Collections.

Using calzone #

Please refer to the Wiki on how to use calzone, starting with Creating a Stub, then Internal Workings. For most usecases, you'll want to use the high-level Builder abstraction.

For an example of using Builder, please refer to test/, or to sdk-dslink-javascript.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  calzone: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:calzone/analysis.dart';
import 'package:calzone/builder.dart';
import 'package:calzone/compiler.dart';
import 'package:calzone/patcher.dart';
import 'package:calzone/transformers.dart';
import 'package:calzone/util.dart';
import 'package:calzone/visitor_typescript.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.10.0 <2.0.0