calendar_widget 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

calendar_widget #

A flutter package for a simple but customizable month view calendar widget.

Getting Started #

For installation information see here

Properties #

RequiredNameTypeDefault Value
NohighlighterCalendarHighlighterno highlighting
Noheightdoublecalculated based on width
NohighlightColorColortheme accent color

Example #

See folder example/ for an example of usage.

calendar usage example

[0.1.0] - 1/16/2019

  • added ability to allow for scrolling to the future

[0.0.6] - 1/5/2019

  • updated license

[0.0.5] - 1/5/2019

  • added recording of usage example

[0.0.4] - 1/5/2019

  • added example

[0.0.3] - 1/5/2019

  • removed log statements

[0.0.2] - 1/5/2019

  • Added license information

[0.0.1] - 1/5/2019

  • First release! Everything should be working as described. Will upload more detailed README in the future


calendar_widget_example #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  calendar_widget: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:calendar_widget/calendar_widget.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/calendar_widget.dart.

Run flutter format to format lib/calendar_widget.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
intl ^0.15.7 0.15.8 0.16.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies