bullseye_request 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 47

Bullseye #

pipeline report

Bullseye is a HTTP request library built on Dart.

Testing #

From the root of the project: pub run test

IF that is not working (git bash related): dart tests/filename_test.dart

Goal icon by Icons8

[1.0.1] - 11/19/2019 #

fixes for pub.dev ratings

[1.0.0] - 11/01/2019 #

initial publish

example/main.dart

import 'package:bullseye_request/bullseye.dart';
import 'package:http/http.dart';

const String testAPI = 'https://jsonplaceholder.typicode.com/';

Bullseye bullseye = Bullseye({
  'baseUrl': testAPI,
  'headers': {
    'Authorization': 'Bearer: fake-auth',
    'Content-Type': 'application/json'
  }
});

void main() async {
  Response response = await bullseye.get();

  print(response.body);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bullseye_request: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bullseye_request/bullseye.dart';
import 'package:bullseye_request/request/baseRequest.dart';
import 'package:bullseye_request/tools/errors/bullseye.dart';
import 'package:bullseye_request/tools/errors/request.dart';
import 'package:bullseye_request/tools/helpers.dart';
import 'package:bullseye_request/tools/types.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Health suggestions

Fix lib/request/baseRequest.dart. (-2.96 points)

Analysis of lib/request/baseRequest.dart reported 6 hints, including:

line 22 col 13: Unnecessary new keyword.

line 42 col 16: Unnecessary new keyword.

line 67 col 16: Unnecessary new keyword.

line 95 col 16: Unnecessary new keyword.

line 115 col 36: Unnecessary new keyword.

Fix lib/bullseye.dart. (-0.50 points)

Analysis of lib/bullseye.dart reported 1 hint:

line 19 col 13: Unnecessary new keyword.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (xml).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
http ^0.12.0+2 0.12.1
test ^1.8.0 1.15.2
xml ^3.2.0 3.7.0 4.2.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
args 1.6.0
async 2.4.2
boolean_selector 2.0.0
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
convert 2.1.1
coverage 0.14.0
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
html 0.14.0+3
http_multi_server 2.2.0
http_parser 3.1.4
io 0.3.4
js 0.6.2
logging 0.11.4
matcher 0.12.8
meta 1.2.2 1.3.0-nullsafety
mime 0.9.6+3
node_interop 1.1.1
node_io 1.1.1
node_preamble 1.4.12
package_config 1.9.3
path 1.7.0
pedantic 1.9.2
petitparser 3.0.4
pool 1.4.0
pub_semver 1.4.4
shelf 0.7.7
shelf_packages_handler 2.0.0
shelf_static 0.2.8
shelf_web_socket 0.2.3
source_map_stack_trace 2.0.0
source_maps 0.10.9
source_span 1.7.0
stack_trace 1.9.5
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.17
test_core 0.3.10
typed_data 1.2.0 1.3.0-nullsafety
vm_service 4.1.0
watcher 0.9.7+15
web_socket_channel 1.1.0
webkit_inspection_protocol 0.7.3
yaml 2.2.1