bullseye 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 0


Bullseye is a new flavour of regex for Dart, because JavaScript's regex flavour sucks quite a lot.

Some things Bullseye has that JS regex doesn't:

  • Lookbehinds (positive and negative)
  • Variable-length lookaheads

Possible features:

  • Named capturing groups
  • Backtracking
  • Recursion (probably not)

Usage #

A simple usage example:

import 'package:bullseye/bullseye.dart';

void main() {
  NewRegex dart = new NewRegex("ab*");

  print(dart.allMatches("ababbaa")); // => ["ab", "abb", "a", "a"]

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.1.0 #

  • Implemented base regex lib
  • Added support for lookbehinds

0.0.1 #

  • Initial version, created by Stagehand


// Copyright (c) 2017, Hanyuan Li. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:bullseye/bullseye.dart';
import "dart:convert";

void main() {
  NewRegex test = new NewRegex("(?<=a)b*");


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bullseye: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bullseye/bullseye.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0