built_value 7.1.0
built_value: ^7.1.0
built_value: ^8.0.0-nullsafety.0

Dart native js
Flutter Android iOS web

Value types with builders, Dart classes as enums, and serialization. This library is the runtime dependency.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  built_value: ^7.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:built_value/built_value.dart';
224
likes
110
pub points
99%
popularity

Publisher

dart.dev

Value types with builders, Dart classes as enums, and serialization. This library is the runtime dependency.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

built_collection, collection, fixnum, quiver

More

Packages that depend on built_value