bubble_tab_indicator 0.1.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 95

Bubble Tab Indicator #

pub package

A Flutter library to add bubble tab indicator to TabBar.


Getting Started #

Add package from github by adding the following to your pubspec.yaml, pub publication is added later.

    bubble_tab_indicator: "^0.1.4"

Import the library in your file:

import 'package:bubble_tab_indicator/bubble_tab_indicator.dart';

Use the BubbleTabIndicator like this:

new TabBar(
  indicatorSize: TabBarIndicatorSize.tab,
  indicator: new BubbleTabIndicator(
    indicatorHeight: 25.0,
    indicatorColor: Colors.blueAccent,
    tabBarIndicatorSize: TabBarIndicatorSize.tab,

0.1.4 #

  • Updated library description

0.1.3 #

  • Updated library to support dart v2

0.1.2 #

  • Updated Readme and screenshot

0.1.1 #

  • Updated Readme and some code formatting

0.1.0 #

  • Initial open source release


example #

An example for flutter bubble tab indicator

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bubble_tab_indicator: ^0.1.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bubble_tab_indicator/bubble_tab_indicator.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance suggestions

Package is getting outdated. (-12.60 points)

The package was last published 58 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies