btool 0.1.1 copy "btool: ^0.1.1" to clipboard
btool: ^0.1.1 copied to clipboard

Generic build helper tools for flutter

btool #

A build helper for Dart/Flutter projects.

Contains utility for getting/setting various configs such as package version/name, min/target sdk version, etc. through a command-line or Dart import which you can utilize for your build steps.

Getting started #

Install globally #

dart pub global activate btools
# or
flutter pub global activate btools

And then to use:

btools -h

Install locally #

dart pub add [--dev] btools
# or
flutter pub add [--dev] btools

And then to use:

dart run btools -h

Usage #

Usage: btool <command> [...args]

Commands:

get <key>            Get config value
set <key> <value>    Set config value

Available keys:

- minSdkVersion
- targetSdkVersion
- packageVersion
- packageName
- applicationId

Optional flags:

-h, --help           Show help
-v, --version        Show version
-d, --working-dir    Change working directory of script
-V, --verbose        Display debug output

Contributing #

I am developing this package on my free time, so any support, whether code, issues, or just stars is very helpful to sustaining its life. If you are feeling incredibly generous and would like to donate just a small amount to help sustain this project, I would be very very thankful!

Buy Me a Coffee at ko-fi.com

I welcome any issues or pull requests on GitHub. If you find a bug, or would like a new feature, don't hesitate to open an appropriate issue and I will do my best to reply promptly.

If you are a developer and want to contribute code, here are some starting tips:

  1. Fork this repository
  2. Run dart pub get
  3. Make any changes you would like
  4. Create tests for your changes
  5. Update the relevant documentation (readme, code comments)
  6. Create a PR on upstream
0
likes
0
pub points
7%
popularity

Publisher

verified publishercasraf.dev

Generic build helper tools for flutter

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

args, colorize, file, path

More

Packages that depend on btool