bson_codec 0.2.0

bson_codec #

Build Status

This package offers Dart programs a flexible serializer and deserializer for BSON documents.

Highlights #

  • Standard Codec/Converter interface, as established by the standard 'dart:convert' package.
  • Best effort type mapping when serializing/deserializing values.

Examples #

import 'package:bson_codec/bson_codec.dart';

main() {
  final doc = {
    '_id': 5,
    'a': [2, 3, 5]
  List<int> bytes = BSON.encode(doc);
  final root = BSON.decode(bytes);
  print(doc['a'][2]); // 5


JavaScript code w/ scope and decimal128 are not supported yet.

Changelog #

0.2.0 #

  • BsonEncoder/BsonDecoder supports chunked conversions

0.1.0 #

  • Initial version


// Copyright (c) 2016, Kwang Yul Seo. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:io';

import 'package:bson_codec/bson_codec.dart';

main() {
  new File('sample.bson').openRead().transform(new BsonDecoder()).listen(print);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bson_codec: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bson_codec/bson_codec.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0