brick_core 0.0.6
brick_core: ^0.0.6

Dart native js
Flutter Android iOS web

Interfaces and shared helpers for implementing models, adapters, providers, and repositories in Brick, an intuitive way to work with persistent data in Dart.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  brick_core: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:brick_core/core.dart';
import 'package:brick_core/field_serializable.dart';
import 'package:brick_core/query.dart';
2
likes
100
pub points
61%
popularity

Interfaces and shared helpers for implementing models, adapters, providers, and repositories in Brick, an intuitive way to work with persistent data in Dart.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

tshedor@greenbits.com
eric@ericwindmill.com
ewindmill@greenbits.com

License

MIT (LICENSE)

Dependencies

collection

More

Packages that depend on brick_core