braintree 0.2.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

Attention! #

Due to naming conflicts with the native iOS CocoaPods package, this plugin is being discontinued in favor of flutter_braintree.

0.2.0 #

  • Discontinued in favor of flutter_braintree due to name conflict.

0.1.2 #

  • Switch to Android SDK version 4.1.1 (this includes a fix for the Google Payment issue)
  • Tweak example code slightly

0.1.1 #

  • Minor improvements

0.1.0 #

  • Migrate to AndroidX
  • Completely overhaul the API to more closely resemble the native Android Drop-in API
  • Add support for Google Pay (may not work properly yet)
  • Add credit card scanning with card.io

0.0.2 #

  • Improve README.md
  • Add analysis_options.yaml
  • Remove unnecessary dependency in the example build.gradle file

0.0.1 #

  • Add basic Drop-in UI functionality for Android

example/README.md

Braintree example project #

Demonstrates how to use the braintree plugin.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  braintree: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:braintree/braintree.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test