brainfuck 0.1.1

  • Readme
  • Changelog
  • Installing
  • 45

A sample command-line Brainfuck interpreter implemented with Dart language.

Installation #

You can install the command-line tool via dart pub. Just run the command blow.

pub global activate brainfuck

Usage #

brainfuck "YOUR_BRAINFUCK_CODE"

0.1.1 #

  • Adopts modern Dart syntax.

0.1.0 #

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate brainfuck

2. Use it

The package has the following executables:


$ brainfuck

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  brainfuck: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:brainfuck/brainfuck.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
74
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Maintenance suggestions

The package description is too short. (-16 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and brainfuck.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
pedantic ^1.9.0
test ^1.9.4