box2d 0.4.0

  • Readme
  • Changelog
  • Installing
  • 15

###A Dart 2D physics engine

Build Status Coverage Status

This is a Dart port of Java's Box2D libraries.

The Java Box2D library was originally written by Daniel Murphy (status February 2015).

benchmark/bench2d.dart   Benchmark used by Joel Webber
example/index.html       Browser demos as written by Dominic Hamon
lib/                     Port of Daniel Murphy's jbox2d

First Dart port of an earlier version of Box2D library was done by Dominic Hamon. We are grateful for his work.

Not an official Google project

0.4.0 #

  • Breaking: Made package strong-mode compliant (with implicit-casts and implicit-dynamic off). This means many API points are now more strongly typed (num is now double). Fix errors by providing doubles where they are expected (1 will become 1.0 and num fraction = .5 will become double fraction = .5), and explicitly casting joints (world.createJoint(jointDef) as RevoluteJoint).
  • Pulled in optimizations and bug fixes from the original jbox2d project.
  • Made velocityThreshold mutable (as per jbox2d and other box2d implementations).

0.3.0 #

  • Updated to vector_math 2.0.0

0.2.0 #

  • Complete re-write. Many APIs have changed.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  box2d: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:box2d/box2d.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.