bottom_line 0.0.4

bottom_line #

This package is under development. The API is unstable and may change.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bottom_line: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bottom_line/bottom_line.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4

Health issues and suggestions

Document public APIs. (-1 points)

40 out of 40 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/locker.dart. (-2.96 points)

Analysis of lib/src/locker.dart reported 6 hints, including:

line 14 col 9: Avoid shadowing type parameters.

line 20 col 13: Avoid shadowing type parameters.

line 26 col 9: Avoid shadowing type parameters.

line 31 col 14: Avoid shadowing type parameters.

line 39 col 12: Avoid shadowing type parameters.

Fix lib/src/exponential_backoff.dart. (-1.99 points)

Analysis of lib/src/exponential_backoff.dart reported 4 hints:

line 52 col 3: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 53 col 3: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 68 col 14: Use = to separate a named parameter from its default value.

line 68 col 32: Use = to separate a named parameter from its default value.

Fix lib/src/json_tool.dart. (-1 points)

Analysis of lib/src/json_tool.dart reported 2 hints:

line 53 col 50: Use = to separate a named parameter from its default value.

line 79 col 52: Use = to separate a named parameter from its default value.

Fix additional 13 files with analysis or formatting issues. (-3.50 points)

Additional issues in the following files:

  • lib/src/map_utilities.dart (2 hints)
  • lib/src/mock_service.dart (2 hints)
  • lib/src/type_utilities.dart (2 hints)
  • lib/src/list_utilities.dart (1 hint)
  • lib/bottom_line.dart (Run dartfmt to format lib/bottom_line.dart.)
  • lib/json_tool.dart (Run dartfmt to format lib/json_tool.dart.)
  • lib/jsonable.dart (Run dartfmt to format lib/jsonable.dart.)
  • lib/locker.dart (Run dartfmt to format lib/locker.dart.)
  • lib/src/bottom_line.dart (Run dartfmt to format lib/src/bottom_line.dart.)
  • lib/src/jsonable.dart (Run dartfmt to format lib/src/jsonable.dart.)
  • lib/src/uuid4.dart (Run dartfmt to format lib/src/uuid4.dart.)
  • lib/time_utilities.dart (Run dartfmt to format lib/time_utilities.dart.)
  • lib/uuid4.dart (Run dartfmt to format lib/uuid4.dart.)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bottom_line.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
uuid ^2.0.2 2.0.4
Transitive dependencies
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
typed_data 1.1.6
Dev dependencies
test ^1.3.3