bootstrapped 0.1.0

  • Installing
  • Versions
  • 0

bootstrapped #

Build Status

A collection of over_react components for the Bootstrap framework.

This library aims to provide over_react statically typed component builders for the [Bootstrap][Bootstrap] framework.

Examples #

void main() {
    final container = (Container())([
            (Column()..constraints = [
                new ColumnConstraint(width: ColumnWidth.six),
            ])('1 of 3'),
            (Column())('2 of 3'),
            (Column())('3 of 3'),

    react_dom.render(container, querySelector('#content'));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bootstrapped: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bootstrapped/bootstrapped.dart';
Version Uploaded Documentation Archive
0.1.0 Feb 5, 2017 Go to the documentation of bootstrapped 0.1.0 Download bootstrapped 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0