boolean_selector 1.0.3

  • Installing
  • Versions
  • 47

The boolean_selector package defines a simple and flexible syntax for boolean expressions. It can be used for filtering based on user-defined expressions. For example, the test package uses boolean selectors to allow users to define what platforms their tests support.

The boolean selector syntax is based on a simplified version of Dart's expression syntax. Selectors can contain identifiers, parentheses, and boolean operators, including ||, &&, !, and ? :. Any valid Dart identifier is allowed, and identifiers may also contain hyphens. For example, chrome, chrome || content-shell, and js || (vm && linux) are all valid boolean selectors.

A boolean selector is parsed from a string using new BooleanSelector.parse(), and evaluated against a set of variables using BooleanSelector.evaluate(). The variables may be supplied as a list of strings, or as a function that takes a variable name and returns its value. For example:

import 'package:boolean_selector/boolean_selector.dart';

void main(List<String> args) {
  var selector = new BooleanSelector.parse("(x && y) || z");
  print(selector.evaluate((variable) => args.contains(variable)));

Versioning #

If this package adds new features to the boolean selector syntax, it will increment its major version number. This ensures that packages that expose the syntax to their users will be able to update their own minor versions, so their users can indicate that they rely on the new syntax.

1.0.3 #

  • Work around an inference bug in the new common front-end.

1.0.2 #

  • Declare compatibility with string_scanner 1.0.0.

1.0.1 #

  • Fix all strong mode warnings.

1.0.0 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  boolean_selector: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:boolean_selector/boolean_selector.dart';
Version Uploaded Documentation Archive
1.0.5 Jun 19, 2019 Go to the documentation of boolean_selector 1.0.5 Download boolean_selector 1.0.5 archive
1.0.4 Jul 12, 2018 Go to the documentation of boolean_selector 1.0.4 Download boolean_selector 1.0.4 archive
1.0.3 Mar 6, 2018 Go to the documentation of boolean_selector 1.0.3 Download boolean_selector 1.0.3 archive
1.0.2 Jun 21, 2016 Go to the documentation of boolean_selector 1.0.2 Download boolean_selector 1.0.2 archive
1.0.1 Apr 1, 2016 Go to the documentation of boolean_selector 1.0.1 Download boolean_selector 1.0.1 archive
1.0.0 Feb 18, 2016 Go to the documentation of boolean_selector 1.0.0 Download boolean_selector 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0