bloc 8.1.3 copy "bloc: ^8.1.3" to clipboard
bloc: ^8.1.3 copied to clipboard

A predictable state management library that helps implement the BLoC (Business Logic Component) design pattern.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add bloc

With Flutter:

 $ flutter pub add bloc

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  bloc: ^8.1.3

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:bloc/bloc.dart';
2629
likes
140
pub points
99%
popularity
screenshot

Publisher

verified publisherbloclibrary.dev

A predictable state management library that helps implement the BLoC (Business Logic Component) design pattern.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#bloc #state-management

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

meta

More

Packages that depend on bloc