bitpanda_api 0.1.0

  • Readme
  • Changelog
  • Installing
  • 37

bitpanda_api #

Coming soon.

This project will be a Dart API wrapper package written for Bitpanda's Public API.

0.1.0 #

😆 Initial release, a beautiful empty package!

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bitpanda_api: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bitpanda_api/bitpanda_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
36
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/bitpanda_api.dart.

Run dartfmt to format lib/bitpanda_api.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/dartsidedev/bitpanda_api was unreachable.

Documentation URL doesn't exist. (-10 points)

At the time of the analysis the documentation field https://pub.dev/documentation/bitpanda_api was unreachable.

Issue tracker URL doesn't exist. (-10 points)

At the time of the analysis the issue_tracker field https://github.com/dartsidedev/bitpanda_api/issues was unreachable.

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bitpanda_api.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
test ^1.6.5