bitbucket_code_coverage 0.0.2

  • Readme
  • Changelog
  • Installing
  • 56

bitbucket_code_coverage #

Build Status codecov

Converts coverage data from LCOV and publishes to Bitbucket server with Bitbucket Server Code Coverage Plugin installed.

Usage #

Add bitbucket_code_coverage to dev_dependencies.

dev_dependencies:
  bitbucket_code_coverage: ^0.0.1

Run the executable for a single coverage file.

pub run bitbucket_code_coverage \
  --url http://localhost:7990 \
  -u <username> \
  -p <password> \
  post \
  -c <commit_id> \
  -f build/lcov.info

In order to publish data from multiple coverage files use --file-pattern option. If you would like to use Personal Access Token you can do so by passing it to -t option.

pub run bitbucket_code_coverage \
    --url http://localhost:7990 \
    -t <personal_access_token> \
    post \
    -c <commit_id> \
    --file-pattern **/lcov.info

0.0.2 #

  • Lower meta dependency version

0.0.1 #

  • Add bitbucket_code_coverage executable

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate bitbucket_code_coverage

2. Use it

The package has the following executables:


$ bitbucket_code_coverage

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bitbucket_code_coverage: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bitbucket_code_coverage/bitbucket_code_coverage.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:bitbucket_code_coverage/bitbucket_code_coverage.dart with components: io.

Health issues and suggestions

Document public APIs. (-0.14 points)

33 out of 34 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/bitbucket_code_coverage_command_runner.dart.

Run dartfmt to format lib/src/bitbucket_code_coverage_command_runner.dart.

Format lib/src/client/code_coverage_service.dart.

Run dartfmt to format lib/src/client/code_coverage_service.dart.

Format lib/src/client/coverage_converter/lcov/path_prefix_finder.dart.

Run dartfmt to format lib/src/client/coverage_converter/lcov/path_prefix_finder.dart.

Fix additional 7 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/client/coverage_converter/lcov/report_to_commit_coverage_mapper.dart (Run dartfmt to format lib/src/client/coverage_converter/lcov/report_to_commit_coverage_mapper.dart.)
  • lib/src/client/coverage_converter/lcov_coverage_converter.dart (Run dartfmt to format lib/src/client/coverage_converter/lcov_coverage_converter.dart.)
  • lib/src/client/model/commit_coverage.dart (Run dartfmt to format lib/src/client/model/commit_coverage.dart.)
  • lib/src/client/model/coverage_string.dart (Run dartfmt to format lib/src/client/model/coverage_string.dart.)
  • lib/src/client/model/file_coverage.dart (Run dartfmt to format lib/src/client/model/file_coverage.dart.)
  • lib/src/command/post/converter_strategy.dart (Run dartfmt to format lib/src/command/post/converter_strategy.dart.)
  • lib/src/command/post/post_command.dart (Run dartfmt to format lib/src/command/post/post_command.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (json_annotation, lcov).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bitbucket_code_coverage.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
args ^1.4.0 1.5.2
collection ^1.14.0 1.14.12
glob ^1.1.0 1.2.0
http ^0.12.0 0.12.0+2
json_annotation ^2.0.0 2.4.0 3.0.0
lcov ^4.1.0 4.5.0 5.4.0
logging ^0.11.0 0.11.3+2
meta ^1.1.0 1.1.8
path ^1.6.0 1.6.4
quiver ^2.0.0 2.1.2+1
Transitive dependencies
async 2.4.0
charcode 1.1.2
http_parser 3.1.3
js 0.6.1+1
matcher 0.12.6
node_interop 1.0.3
node_io 1.0.1+2
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_runner ^1.0.0
json_serializable ^2.0.2
mock_web_server ^4.0.0
pedantic ^1.4.0 1.8.0+1
test ^1.5.3
test_coverage ^0.2.3
test_descriptor ^1.0.0