big5 0.0.4

big5-dart #

This package provides encode, decode method for big5.

Usage #

To use this plugin, add big5 to your package's pubspec.yaml file

big5.decode([119, 111, 114, 100]);

stream version and encode method is ongoing.

This packages is fork from douasin/big5-dart re-upload version.

[0.0.1] - 2018/05/26

  • add decode method

[0.0.2] - 2018/05/26

  • remote some comments that make flutter fmt failed.

[0.0.3] - 2018/05/26

  • add encode method

[0.0.4] - 2019/08/06

  • upgrade minimum dart sdk to 2.1.0
  • improve decode performance in long word

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  big5: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:big5/big5.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Document public APIs. (-1 points)

35 out of 35 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/big5.dart. (-1.49 points)

Analysis of lib/big5.dart reported 3 hints:

line 25 col 8: Name non-constant identifiers using lowerCamelCase.

line 30 col 7: The value of the local variable 'nSrc' isn't used.

line 66 col 11: Name non-constant identifiers using lowerCamelCase.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and big5.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies