big5 0.0.3

big5-dart #

This package provides encode, decode method for big5.

Usage #

To use this plugin, add big5 to your package's pubspec.yaml file

big5.encode('word');
big5.decode([119, 111, 114, 100]);

stream version and encode method is ongoing.

[0.0.1] - 2018/05/26

  • add decode method

[0.0.2] - 2018/05/26

  • remote some comments that make flutter fmt failed.

[0.0.3] - 2018/05/26

  • add encode method

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  big5: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:big5/big5.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
4
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0

Admin