bgg 0.1.0

bgg # API Client for Dart and Flutter.

Warning: This is not an official Google or Dart project.

Usage #

// Prints the game matching ID#2536.
// Then prints all games with "Letters" in the title.
main() async {
  var http = new BggHttp();
  var bgg = new Bgg(http);
  var result = await bgg.getBoardGame(2536);
  var search = await bgg.searchGames('Letters');
  print('\nGames matching "Letters": ');
  print('* ' + =>'\n* '));

0.1.0 #

  • Initial commit.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bgg: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bgg/bgg.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0