bflutter 0.1.8+3

bflutter #

BeeSight Soft Flutter core using BLoC Design Pattern (Business Logic Component)

Newbie #

Flutter package #

https://pub.dartlang.org/packages/bflutter

[0.1.8+3] - Dec 05, 2019.

  • Option init BCache

[0.1.8+2] - Dec 05, 2019.

  • Remove unused

[0.1.8+1] - Dec 05, 2019.

  • Update readme

[0.1.8] - Dec 05, 2019.

  • Add i18n approach
  • Remove http, cached_network_image out of core

[0.1.7] - Oct 30, 2019.

  • Get context from main_bloc
  • Show dialog with full builder customization

[0.1.6] - Oct 30, 2019.

  • Add logging

[0.1.5+3] - Oct 28, 2019.

  • Fix login bloc in example
  • Remove close keyboard on main_bloc, it break Observable

[0.1.5+2] - Oct 28, 2019.

  • Fix import in example

[0.1.5+1] - Oct 28, 2019.

  • Update dependencies

[0.1.5] - Oct 28, 2019.

  • Add network, loading, popup widget
  • Update example project

[0.1.4] - Oct 09, 2019.

  • Change Piece property name
  • Proving more option for bcache

[0.1.3] - Oct 08, 2019.

  • Get input stream, update example

[0.1.2] - Oct 07, 2019.

  • Local caching available

[0.1.1+2] - Oct 07, 2019.

  • Update example

[0.1.1+1] - Oct 07, 2019.

  • Update pub template

[0.1.1] - Oct 07, 2019.

  • Add example to core

[0.1.0] - Oct 04, 2019.

[0.0.3] - Dec 12, 2018.

[0.0.2] - Dec 6, 2018.

  • Initial simple Bloc.

[0.0.1] - Dec 6, 2018.

  • Initial release.

example/README.md

bflutter_poc #

BeeSight Soft Flutter Core Proof of concept

Integrate bflutter in dev mode #

dependencies:
  ...
  bflutter:
    path: ../

Structure #

                                                     
     main.dart                                       
         |                                           
 +-------|------+                                    
 |     login     |                                    
 +--------------+                                    
 - Login with fake api                                    
         |                                           
 +-------|------+                                    
 |     home     |                                    
 +--------------+                                    
 - Show repo info                                    
 - Navigate to search screen                         
         |                                           
         |                                           
 +-------|------+                                    
 |    search    |                                    
 +--------------+                                    
 - Search github user                                
 - Show a list of user                               
 - Tap on specific user and navigate to detail screen
         |                                           
         |                                           
 +-------|------+                                    
 |    detail    |                                    
 +--------------+                                    
 - Show detail of github user                        

Update app icon #

flutter pub get
flutter pub run flutter_launcher_icons:main

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bflutter: ^0.1.8+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bflutter/bflutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
connectivity ^0.4.5+7 0.4.8+1
flutter 0.0.0
flutter_spinkit ^4.1.0 4.1.2
path ^1.6.4 1.6.4
rxdart ^0.22.6 0.22.6 0.23.1
sqflite ^1.1.8 1.2.1
uuid ^2.0.4 2.0.4
Transitive dependencies
charcode 1.1.3
collection 1.14.11 1.14.12
connectivity_macos 0.1.0+1
connectivity_platform_interface 1.0.3
convert 2.1.1
crypto 2.1.4
meta 1.1.8
plugin_platform_interface 1.0.2
sky_engine 0.0.99
synchronized 2.2.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test