batch_flutter 1.0.0-rc.2
batch_flutter: ^1.0.0-rc.2 copied to clipboard

Batch.com Flutter Plugin. Batch Flutter Plugin allows you to build meaningful communication experience in your iOS app through highly personalized push notifications and In-App messages.

Batch Logo

Batch Flutter Plugin #

The Batch Flutter Plugin allows you to build meaningful communication experience in your iOS app through highly personalized push notifications & In-App messages.

Our 📕 setup documentation details the steps to take for an easy and successful integration.

Prerequisites #

The Batch Flutter Plugin requires Flutter 2 and Dart 2.12 or higher.

As this plugin is built over Batch's Native SDKs, their respective Android and iOS requirements apply.

Documentation #

  • Setup guide: start your implementation here!
  • Help center: answers to most questions you may have during the integration
  • API reference: this documents each of the classes and methods in the Batch Flutter Plugin

You may also find this guide useful to review after integration to make sure you're ready to go live: How can I test the integration on iOS? / How can I test the integration on Android?

Releases #

The plugin is available on pub.dev.

Building #

Build instructions are detailed in BUILDING.md.

Contributing #

Please refer to our contributing guidelines.

0
likes
110
pub points
63%
popularity

Publisher

batch.com

Batch.com Flutter Plugin. Batch Flutter Plugin allows you to build meaningful communication experience in your iOS app through highly personalized push notifications and In-App messages.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on batch_flutter