basics 0.2.0 copy "basics: ^0.2.0" to clipboard
basics: ^0.2.0 copied to clipboard

outdated

A Dart library containing convenient extension methods on basic Dart objects.

Dart Basics #

This repository contains a collection of useful extension methods on the built in objects in Dart, such as Strings, Collections, and Object.

Usage #

Import the basics library.

import 'package:basics/basics.dart';

Then use the methods directly on objects in your dart code.

List<int> numbers;

if (numbers.isNull) {
  print('numbers is uninitialized').
}

numbers = [2, 4, 8];

if (numbers.isNotNull && numbers.all(isEven)) {
  print('all numbers are even');
}

Notes #

This is not an official Google project.

94
likes
0
pub points
92%
popularity

Publisher

verified publishergoogle.dev

A Dart library containing convenient extension methods on basic Dart objects.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

quiver

More

Packages that depend on basics