barcode_scan_javalite 1.0.1
barcode_scan_javalite: ^1.0.1 copied to clipboard

A flutter plugin for scanning 2D barcodes and QRCodes via camera.

v3.0.1 - 2020-05-08 #

Features:

Bugfixes:

v3.0.0 - 2020-04-18 #

Bugfixes:

v3.0.0-dev.3 - 2020-04-14 #

Bugfixes:

v3.0.0-dev.2 - 2020-04-12 #

Migrated the changes of the 2.0.0 track

  • Fixed the request camera permission flow on Android

Updated also the Flutter env. SDK constraint to ">=2.1.0 <3.0.0"

v3.0.0-dev.1 - 2020-04-12 #

Changes:

  • Rewrite platform communication - @devtronic
    • This provides a better way to configure the plugin
    • iOS code migrated to Swift
    • Android code migrated to FlutterPlugin
    • Platform communication with protobuf
    • Retrieve the number of available cameras with BarcodeScanner.numberOfCameras
    • Flexible configuration:
    • Set the strings for the flash on/off and the cancel button
    • Restrict the detected barcode formats
    • Set which camera is used for scanning barcodes

BREAKING CHANGES:

  • minSdk version on Android is now 18
  • BarcodeScanner.scan() returns a ScanResult object. Check UPGRADE.md for migration details.

v2.0.2 - 2020-04-14 #

Bugfixes:

v2.0.1 - 2020-02-19 #

Bugfixes:

  • Fixed wrong build.gradle

v2.0.0 - 2020-02-19 #

Features:

Bugfixes:

Changes:

  • Fix compile warning - @lookfirst
  • Upgrade gradle - @SuuSoJeat
    • com.android.tools.build:gradle: 3.3.1 -> 3.5.0
    • org.jetbrains.kotlin:kotlin-gradle-plugin: 1.3.20 -> 1.3.50
    • compileSdkVersion: 28 -> 29
    • targetSdkVersion: 28 -> 29
    • gradle: 4.10.2 -> 5.4.1
  • Package description updated - @connectety
  • README.md and LICENSE.md updated
  • Since the project owner has been changed, the package names are different. Checkout the UPGRADE.md for details.

v1.0.0 - 2018-08-30 #

Breaking Change: Adds support for AndroidX

v0.0.8 - 2018-08-30 #

v0.0.7 - 2018-08-30 #

  • Fix iOS barcodes not scanning

v0.0.6 - 2018-08-29 #

  • Fix android dependencies
  • iOS scanner now looks like Android thanks to @dustin-graham

v0.0.4 - 2018-02-8 #

  • Fix missing gradle dependency (thanks to toteto)
  • Update gradle dependencies

v0.0.3 - 2017-02-8 #

  • Improved permission handling (thanks to BenSower)
  • Added MIT license

v0.0.2 - 2017-11-7 #

v0.0.1 - 2017-10-29 #

  • Supports 2D & QR Codes
  • Control flash while scanning
0
likes
100
pub points
0%
popularity

A flutter plugin for scanning 2D barcodes and QRCodes via camera.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter, protobuf

More

Packages that depend on barcode_scan_javalite