barcode_scan2 4.3.0 copy "barcode_scan2: ^4.3.0" to clipboard
barcode_scan2: ^4.3.0 copied to clipboard

A flutter plugin for scanning 2D barcodes and QRCodes via camera.

4.3.0 #

  • Upgrade min Flutter version to 3.0.1
  • Upgrade protobuf dependency to ^3.1.0
  • Upgrade pedantic_mono dev_dependency to pedantic_mono: ^1.24.0+1

4.2.4 #

  • Update Kotlin Gradle plugin version 1.5.20 (#65)

4.2.3 #

  • zxing version 1.9.13 does not exist in the mavenCentral (#60)

4.2.2 #

  • Migrate from JCenter to Maven Central for gradle dependencies (#57)

4.2.1+1 #

  • Fix README (#59)

4.2.1 #

  • Fix compile error (#48, #49)

4.2.0 #

  • Changed protobuf_version and compileSdkVersion to support Android 12 / SDK 31

4.1.4 #

  • Broken artifact fixes for Apple Silicon M1 (#28)

4.1.3 #

4.1.2 #

  • Fix Error in release mode (#9)

4.1.1 #

  • Fix After flutter plugin register, the topViewController may changed, present Scan ViewController failed! (#10)

4.1.0 #

  • Lock screen rotation when scanner is shown (#7)

4.0.1 #

  • Fix When ViewController whose view is not in the window hierarchy, present Scan ViewController failed will failed. (#5)

4.0.0 #


Prior to 3.0.1, see the CHANGELOG of discontinued original package: https://pub.dev/packages/barcode_scan/changelog

258
likes
130
pub points
98%
popularity

Publisher

verified publishermono0926.com

A flutter plugin for scanning 2D barcodes and QRCodes via camera.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, protobuf

More

Packages that depend on barcode_scan2