barcode_flutter 1.1.0

Barcode Flutter is a Flutter library for simple and fast Barcode rendering via custom painter

screenshot


Update Notes #

1.1.0

  • Add ITF support
  • Add BarCodeParams class for future expandability

1.0.2

  • Fix EAN8 code invalid checksum bug

1.0.1

  • Fix issue. Scanning problem when code128 contains character 'M'

1.0.0

  • Initial release

Features #

  • Supports code type: Code39, Code93, Code128, EAN13, EAN8, UPCA, UPCE
  • Supports render with or without text label
  • Supports adjusting the bar width
  • No internet connection required

Installing #

You can install the package by adding the following lines to your pubspec.yaml:

dependencies:
    barcode_flutter: ^1.1.0

After adding the dependency to your pubspec.yaml you can run: flutter packages get or update your packages using your IDE.

Getting started #

To start, import the dependency in your code:

import 'package:barcode_flutter/barcode_flutter.dart';

Next, to reander a Barcode (Code39 for example), you can use the following code:

BarCodeImage(
  params: Code39BarCodeParams(
    "1234ABCD",
    lineWidth: 2.0,                // width for a single black/white bar (default: 2.0)
    barHeight: 90.0,               // height for the entire widget (default: 100.0)
    withText: true,                // Render with text label or not (default: false)
  ),
  onError: (error) {               // Error handler
    print('error = $error');
  },
);

NOTE: You can only tweak the lineWidth parameter to change the entire widget's width. But value less than 2.0 will sometimes make the barcode scaner more difficult to recognize result correctly. 2.0 is a safe value for all code types.

Error handling: You have to make sure the code strings provided are valid. If you are not sure about the data, maybe it comes from user input or something, then setup onError method, and put your error handling logic there. Sometimes the library will render parts of the barcode if the data is invalid, and if that happens, I can't guarantee that the result can be recognized by a barcode scaner.

Example #

See the example directory for a basic working example.

FAQ #

Has it been tested in production? Can I use it in production? #

Yep! I've test it both on Android and iOS devices. Feel free to test it with any barcode scanner.

How about the other barcode types ? #

I've only implemented some most commonly used barcode types. But feel free to send PR to include more barcode types.

License #

Barcode flutter is released under BSD license. See LICENSE for details.

1.0.0 #

  • Initial release

1.0.1 #

  • Fix issue. Scanning problem when code128 contains character 'M'

1.0.2 #

  • Fix EAN8 code invalid checksum bug

1.1.0 #

  • Add BarCodeParams which allow custom params for each barcode type
  • Add ITF support
  • Fix issue #1, #9, #13 (See github page for details)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  barcode_flutter: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:barcode_flutter/barcode_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
92
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
88
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Fix lib/src/barcode_image.dart. (-7.71 points)

Analysis of lib/src/barcode_image.dart reported 16 hints, including:

line 37 col 22: 'data' is deprecated and shouldn't be used.

line 38 col 22: 'codeType' is deprecated and shouldn't be used.

line 39 col 22: 'lineWidth' is deprecated and shouldn't be used.

line 40 col 22: 'barHeight' is deprecated and shouldn't be used.

line 41 col 22: 'hasText' is deprecated and shouldn't be used.

Format lib/src/barcode_enum.dart.

Run flutter format to format lib/src/barcode_enum.dart.

Format lib/src/barcode_painter.dart.

Run flutter format to format lib/src/barcode_painter.dart.

Format lib/src/barcode_params.dart.

Run flutter format to format lib/src/barcode_params.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and barcode_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Update README.md. (-2 points)

1 image link is insecure (e.g. http://i.imgur.com/qW856Dh.png), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.58.0 < 3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8