banner_view 1.1.2

  • Readme
  • Changelog
  • Installing
  • 78

banner_view #

A flutter BannerView package project.

Demo #

Visit Demo in here.

function #

Getting Started #

add in pubspec.yaml

    banner_view: "^1.1.2"
    or
    banner_view: 
        git: https://github.com/yangxiaoweihn/BannerView.git
    import 'package:banner_view/banner_view.dart';
    new Container(
        alignment: Alignment.center,
        height: 200.0,
        child: new BannerView(
            [...]
        ),
    );

support properties:

    final List<Widget> banners;
    //init index
    final int initIndex;
    //switch interval
    final Duration intervalDuration;
    //animation duration
    final Duration animationDuration;
    final IndicatorContainerBuilder indicatorBuilder;
    final Widget indicatorNormal;
    final Widget indicatorSelected;
    //the margin of between indicator items
    final double indicatorMargin;
    final PageController controller;
    //whether cycyle rolling
    final bool cycleRolling;
    //whether auto rolling
    final bool autoRolling;
    final Curve curve;
    final ValueChanged onPageChanged;

Flutter QQ group ( 714494675 ) #

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  banner_view: ^1.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:banner_view/banner_view.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
39
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/banner_view.dart. (-0.50 points)

Analysis of lib/banner_view.dart reported 1 hint:

line 211 col 29: This function has a return type of 'bool', but doesn't end with a return statement.

Format lib/indicator/IndicatorUtil.dart.

Run flutter format to format lib/indicator/IndicatorUtil.dart.

Format lib/indicator/IndicatorWidget.dart.

Run flutter format to format lib/indicator/IndicatorWidget.dart.

Maintenance suggestions

Package is getting outdated. (-30.96 points)

The package was last published 68 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and banner_view.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test