banner 0.1.3

BannerView #

flutter的轮播图控件

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

###属性

  • data 传入list<*>
  • onBannerClickListener(index,itemData) 点击事件
  • delayTime 秒 延迟多少秒进入下一页
  • scrollTime 毫秒 滑动至下页需要秒数
  • height 高度
  • buildShowView(index,itemData) 返回一个用于展示的widget

###例子

    new BannerView(
          data: ['a', 'b', 'c'],
          buildShowView: (index,data) {
            print(data);
            return new CustomWidget(text: data);
          },
          onBannerClickListener: (index,data){
            print(index);
          },
        ),

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  banner: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:banner/banner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Jul 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/banner.dart. (-1 points)

Analysis of lib/banner.dart reported 2 hints:

line 54 col 26: The member 'positions' can only be used within instance members of subclasses of 'package:flutter/src/widgets/scroll_controller.dart'.

line 72 col 12: The value of the local variable 'screenWidth' isn't used.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and banner.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin