bad_words 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 72

bad_words #

A dart filter for English bad words.

Installation #

bad_words: ^0.1.0

Usage #

import 'package:bad_words/bad_words.dart';

final filter = Filter();

if (filter.isProfane('some string to test')) {
    // ... validation error etc.

[0.1.0] - August 29, 2019.

Initial release. Includes blacklist of words checking if the string contains profane language. Only in English.

[0.1.1] - September 2, 2019.

Clean up the example.dart file.

[0.1.2] - September 2, 2019.

Update README example to use latest version.


import 'package:bad_words/bad_words.dart';

main() {
  final testString = 'string that does not contain bad words';
  final filter = Filter();

  if (filter.isProfane(testString)) {
    print('put a nickle in the swear jar!');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bad_words: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bad_words/bad_words.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies