backederrorlink 0.0.2

  • Readme
  • Changelog
  • Installing
  • 38

backederrorlink #

BackendErrorLink for graphql_flutter

Getting Started #

final BackendErrorLink backendErrorLink = BackendErrorLink(
    onUnauthorized: (FetchResult result, StreamedResponse response) {
    expect(new Future.value(response.statusCode), completion(equals(401)));

final HttpLink httpLink = HttpLink(

final Link link = backendErrorLink.concat(httpLink as Link);

GraphQLClient graphQLClient = GraphQLClient(
    cache: OptimisticCache(
    dataIdFromObject: typenameDataIdFromObject,
    link: link,

await graphQLClient.query(QueryOptions(
    document: '''
        user {

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

[0.0.2] - Fix condition error.

  • Fix condition error.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  backederrorlink: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:backederrorlink/backederrorlink.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

16 out of 16 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (graphql, graphql_flutter).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and backederrorlink.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
graphql ^1.0.1 1.1.0 2.1.0
graphql_flutter ^1.0.1 1.0.1 2.1.0
http ^0.12.0 0.12.0+2
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.3
graphql_parser 1.1.4
http_parser 3.1.3
meta 1.1.7
mime 0.9.6+3
path 1.6.4
path_provider 1.4.0
pedantic 1.8.0+1
platform 2.2.1
rxdart 0.22.4
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
uuid 2.0.2
vector_math 2.0.8
Dev dependencies