baato_navigation 0.0.1
baato_navigation: ^0.0.1 copied to clipboard

Flutter package to consume Baato turn by turn navigation for several modes of transportation, including bike, foot and car.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add baato_navigation

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  baato_navigation: ^0.0.1

Alternatively, your editor might support or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:baato_navigation/embedded/controller.dart';
import 'package:baato_navigation/embedded/view.dart';
import 'package:baato_navigation/library.dart';
import 'package:baato_navigation/models/eventData.dart';
import 'package:baato_navigation/models/events.dart';
import 'package:baato_navigation/models/options.dart';
import 'package:baato_navigation/models/routeEvent.dart';
import 'package:baato_navigation/models/routeLeg.dart';
import 'package:baato_navigation/models/routeProgressEvent.dart';
import 'package:baato_navigation/models/routeStep.dart';
import 'package:baato_navigation/models/wayPoint.dart';
import 'package:baato_navigation/navigationbaato.dart';
0
likes
90
pub points
0%
popularity

Flutter package to consume Baato turn by turn navigation for several modes of transportation, including bike, foot and car.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on baato_navigation