aws_cloudformation_api 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new46

AWS API client for AWS CloudFormation #

Warning: This is a generated library, some operations may not work.

About the service: AWS CloudFormation allows you to create and manage AWS infrastructure deployments predictably and repeatedly. You can use AWS CloudFormation to leverage AWS products, such as Amazon Elastic Compute Cloud, Amazon Elastic Block Store, Amazon Simple Notification Service, Elastic Load Balancing, and Auto Scaling to build highly-reliable, highly scalable, cost-effective applications without creating or configuring the underlying AWS infrastructure.

Contributors #

0.0.1 #

  • initial release

example/README.md

import 'package:aws_cloudformation_api/cloudformation-2010-05-15.dart';

void main() {
  final credentials = AwsClientCredentials(accessKey: '', secretKey: '');
  final service = CloudFormation(region: 'eu-west-1', credentials: credentials);
  // See documentation on how to use CloudFormation
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aws_cloudformation_api: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aws_cloudformation_api/cloudformation-2010-05-15.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: parsing /tmp/pub-dartlang-dartdocTOYVPV/pkg/lib/cloudformation-2010-05-15.dart... parsing /dart-sdk/lib/convert/convert.dart... parsing /dart-sdk/lib/async/async.dart... parsing /dart-sdk/lib/collection/collection.dart... parsing /dart-sdk/lib/internal/internal.dart... parsing /dart-sdk/lib/core/core.dart... parsing /dart-sdk/lib/math/math.dart... parsing /dart-sdk/lib/typed_data/typed_data.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/shared_aws_api-0.1.1/lib/shared.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/http.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/client.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/base_client.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/base_request.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/byte_stream.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/streamed_response.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/base_response.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/utils.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/exception.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http-0.12.0+4/lib/src/request.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/http_parser-3.1.3/lib/http_parser.dart... [...] parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/events/text_event.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/iterable.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/iterator.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/parser.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/codec/event_codec.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/converters/event_decoder.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/codec/node_codec.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/converters/node_decoder.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/converters/node_encoder.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/xml-3.7.0/lib/src/xml_events/converters/normalizer.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/reflection/iterable.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/reflection/optimize.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/reflection/transform.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/debug/profile.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/debug/output.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/debug/progress.dart... parsing /tmp/pub-cache-dirGWFGDS/hosted/pub.dartlang.org/petitparser-3.0.0/lib/src/debug/trace.dart... Initialized dartdoc with 373 libraries in 42.3 seconds documenting aws_cloudformation_api Generating docs for library cloudformation-2010-05-15 from package:aws_cloudformation_api/cloudformation-2010-05-15.dart... stderr: Documenting aws_cloudformation_api... Unhandled exception: type 'DynamicTypeImpl' is not a subtype of type 'InterfaceType' #0 TypeParameterElementType._interfaceType (package:dartdoc/src/element_type.dart:213:39) #1 DefinedElementType.instantiatedType (package:dartdoc/src/element_type.dart:284:12) #2 Extension._couldApplyTo (package:dartdoc/src/model/extension.dart:41:49) #3 Extension.couldApplyTo (package:dartdoc/src/model/extension.dart:31:7) #4 ExtensionTarget.potentiallyApplicableExtensions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
shared_aws_api ^0.1.0 0.1.1
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
http 0.12.0+4
http_parser 3.1.3
json_annotation 3.0.1
meta 1.1.8
path 1.6.4
pedantic 1.9.0
petitparser 3.0.0
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
xml 3.7.0
Dev dependencies
build_runner ^1.7.2
build_verify ^1.1.1
json_serializable ^3.2.0
test ^1.9.4