awesome_ui_button 1.0.0

awesome_ui_button #

License: MIT

This package allows you to add a good looking button to your application easily and without having to write a lot of code yourself, simply import and start using.

Add the dependency #

Add this to your pubspec.yaml

dependencies:
  awesome_ui_button: ^0.0.1

Installing #

Run the following command

flutter pub get

Import the package #

import 'package:awesome_ui_button/awesome_ui_button.dart';

Add the button to your application #

AwesomeButton(
  text: "Default",
),

OR

AwesomeButton.outline(
  text: "Outline",
),


OR

AwesomeButton.destructive(
  text: "Destructive",
),

For full documentation visit flutterawesome.dev

[1.0.0] - Jan 2020.

  • Release of 1.0.0

[0.0.1] - Jan 2020

  • Internal release(do not use in production)

example/README.md

example #

A new Flutter application.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  awesome_ui_button: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:awesome_ui_button/awesome_ui_button.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
7
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Feb 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test