austerity 0.0.10-beta copy "austerity: ^0.0.10-beta" to clipboard
austerity: ^0.0.10-beta copied to clipboard

Dart and Flutter static code analysis, but not for the faint hearted. This code tries to turn all violations in to red squiggly lines

example/main.dart

///These are some of red squiggly lines that you will enjoy
void main() {
  //unused_local_variable
  //prefer_final_locals
  var unused = 'test';

  //literal_only_boolean_expressions
  if (true) {
    //dead_code
  } else {}

  //omit_local_variable_types
  //deprecated_member_use_from_same_package
  SomeDeprecatedClass deprecatedClass = SomeDeprecatedClass();
}

@deprecated
class SomeDeprecatedClass {
  //prefer_expression_function_bodies
  bool test() {
    return true;
  }

  //avoid_final_parameters
  bool test2(final String test) => true;

  //implicit_dynamic_return
  //inference_failure_on_function_return_type
  Test() => true;
}
23
likes
0
pub points
66%
popularity

Publisher

verified publisherchristianfindlay.com

Dart and Flutter static code analysis, but not for the faint hearted. This code tries to turn all violations in to red squiggly lines

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

More

Packages that depend on austerity