auro_avatar 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

Avatar with name initials generated #

Build Status pub package

A flutter plugin to generate an avatar with name initials from a full-name string.

How to import #

Add this to your package's pubspec.yaml file:

dependencies:
  auro_avatar: "^0.1.0"

Add it to your dart file:

import 'package:auro_avatar/auro_avatar.dart';

Usage #

The auro_avatar can be used directly as:

InitialNameAvatar - Circle avatar #

new InitialNameAvatar(
    'John Doe',
    circleAvatar: true,
    borderColor: Colors.grey,
    borderSize: 4.0,
    backgroundColor: Colors.blue,
    foregroundColor: Colors.white,
    padding: 20.0,
    textSize: 30.0,
),

InitialNameAvatar - Square avatar #

new InitialNameAvatar(
    'John Doe',
    circleAvatar: false,
    ...
),

[0.1.1] - 2018-09-22

  • Configured travis-ci.

[0.1.0] - 2018-09-22

Initial release:

  • Added the feature to generate an avatar with name initials.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:auro_avatar/auro_avatar.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await AuroAvatar.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Auro_Avatar plugin example'),
        ),
        body: new Center(
          child: new Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: <Widget>[
              Container(
                child: new InitialNameAvatar(
                  'John Doe',
                  circleAvatar: true,
                  borderColor: Colors.grey,
                  borderSize: 4.0,
                  backgroundColor: Colors.blue,
                  foregroundColor: Colors.white,
                  padding: 20.0,
                  textSize: 30.0,
                ),
              ),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  auro_avatar: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:auro_avatar/auro_avatar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
72
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is getting outdated. (-7.67 points)

The package was last published 56 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_test 0.0.0
Transitive dependencies
async 2.3.0 2.4.0
boolean_selector 1.0.5
charcode 1.1.2
collection 1.14.11 1.14.12
matcher 0.12.5 0.12.6
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
quiver 2.0.5
sky_engine 0.0.99
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.5 0.2.9
typed_data 1.1.6
vector_math 2.0.8