audioplayerui 0.0.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 76

audioplayerui #

Audio Player UI Plugin.

Features #

  • Play (url / local file)
  • Resume / pause

Installation #

First, add audioplayerui as a dependency in your pubspec.yaml file.

Then add the AudioPlayerView like this

  AudioPlayerController audioPlayerController = AudioPlayerController();

  @override
  Widget build(BuildContext context) {
    return AudioPlayerView(
              audioPlayerController: audioPlayerController,
              trackUrl: "",
              isLocal: false,
              trackTitle: "",
              trackSubtitle: "",
              imageUrl: ""
              );
  }

Available methods for AudioPlayerController #

Methoddescriptionparametersnotes
playPlays a audio file from an remote linkurl
playLocalPlays a local audio filepath
pausePause's the currently playing track
resumeResumes the currently paused track
stopStops the playback of the current track

Example #

Demonstrates how to use the audioplayerui plugin.

See the example documentation for more information.

Contributing #

Feel free to contribute by opening issues and/or pull requests. Your feedback is very welcome!

Changelog #

See CHANGELOG.md.

License #

MIT License

Copyright (c) [2019] [Joran Dob] Copyright (c) [2019] [QREATE]

[0.0.6] - 12/11/2019

  • Added example
  • Updated completed status for button

[0.0.5] - 07/11/2019

  • Added reset after track playback completed.

[0.0.4] - 02/10/2019

  • Added autoplay property to controller.

[0.0.3] - 27/08/2019

  • Fixed color for pause button.

[0.0.2] - 23/08/2019

  • Implemented basic ui and functions
  • Resolved some issues

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  audioplayerui: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:audioplayerui/audioplayerui.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Nov 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
audioplayers ^0.13.1 0.13.2
flutter 0.0.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.3
meta 1.1.7 1.1.8
path_provider 1.4.0
platform 2.2.1
sky_engine 0.0.99
typed_data 1.1.6
uuid 2.0.2
vector_math 2.0.8
Dev dependencies
flutter_test