audioplayer_web 0.7.1

  • Readme
  • Changelog
  • Installing
  • 91

Audioplayer for Flutter Web #

online example

screenshot

Installation #

    audioplayer: 0.8.1
    audioplayer_web: 0.7.1  

cf example

0.7.1 #

  • Add a no-op ios implementation to avoid ios compilation error

0.7.0 #

  • First web version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  audioplayer_web: ^0.7.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:audioplayer_web/audioplayer_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
88
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
87
Overall:
Weighted score of the above. [more]
91
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because:

  • package:audioplayer_web/audioplayer_web.dart that declares support for platforms: web

Package does not support Flutter platform ios

Because:

  • package:audioplayer_web/audioplayer_web.dart that declares support for platforms: web

Package does not support Flutter platform linux

Because:

  • package:audioplayer_web/audioplayer_web.dart that declares support for platforms: web

Package does not support Flutter platform macos

Because:

  • package:audioplayer_web/audioplayer_web.dart that declares support for platforms: web

Package does not support Flutter platform windows

Because:

  • package:audioplayer_web/audioplayer_web.dart that declares support for platforms: web

Package not compatible with SDK dart

Because:

  • audioplayer_web that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

19 out of 19 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and audioplayer_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-3 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
flutter_web_plugins 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
audioplayer
flutter_test