audiocutter 0.0.3

  • Example
  • Installing
  • Versions
  • 54

audiocutter #

A plugin to cut audio files. You

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.2 #

  • Implements a class with a static method to cut audio.

0.0.1 #

  • Just the default flutter --template=plugin to start.


audiocutter_example #

Demonstrates how to use the audiocutter plugin.

Getting Started #

View an example in the repo.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  audiocutter: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:audiocutter/audiocutter.dart';
Version Uploaded Documentation Archive
0.0.3 Jan 8, 2019 Go to the documentation of audiocutter 0.0.3 Download audiocutter 0.0.3 archive
0.0.2 Jan 8, 2019 Go to the documentation of audiocutter 0.0.2 Download audiocutter 0.0.2 archive
0.0.1 Dec 19, 2018 Go to the documentation of audiocutter 0.0.1 Download audiocutter 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
path_provider 0.4.1 0.4.1 1.1.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8