audio_recorder2 1.0.3

audio_recorder2 #

audio recorder plug-in

This is fork of audio_recorder by ZaraclaJ, please refer https://github.com/ZaraclaJ/audio_recorder for usgae instructions

(why this plugin? : ZaraclaJ seems inactive and I had urgent need to refactor plugin to swift 4.2)

Usage #

// Import package
import 'package:audio_recorder2/audio_recorder2.dart';

// Check permissions before starting
bool hasPermissions = await AudioRecorder2.hasPermissions;

// Get the state of the recorder
bool isRecording = await AudioRecorder2.isRecording;

// Start recording
await AudioRecorder2.start(path: _controller.text, audioOutputFormat: AudioOutputFormat.AAC);

// Stop recording
Recording recording = await AudioRecorder2.stop();
print("Path : ${recording.path},  Format : ${recording.audioOutputFormat},  Duration : ${recording.duration},  Extension : ${recording.extension},");

0.0.1 #

  • TODO: Describe initial release.

example/README.md

audio_recorder2_example #

Demonstrates how to use the audio_recorder2 plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  audio_recorder2: ^1.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:audio_recorder2/audio_recorder2.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/audio_recorder2.dart.

Run flutter format to format lib/audio_recorder2.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (path_provider).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
file ^5.0.4 5.0.8+1
flutter 0.0.0
path ^1.5.1 1.6.2
path_provider ^0.4.1 0.4.1 1.1.2
Transitive dependencies
collection 1.14.11
intl 0.15.8
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8

Admin