aspen_builder 0.3.0

  • Readme
  • Changelog
  • Installing
  • new46

aspen_builder #

The builder component of Aspen. Please see there for more information.

0.3.0 #

Initial check-in of modernized Aspen.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aspen_builder: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aspen_builder/builder.dart';
import 'package:aspen_builder/loader.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
82
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 6, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with SDK flutter

Because it is not compatible with any of the supported runtimes: flutter-native, flutter-web

Package not compatible with runtime flutter-native on android

Because of the import of dart:mirrors via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime flutter-native on ios

Because of the import of dart:mirrors via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime flutter-native on linux

Because of the import of dart:mirrors via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime flutter-native on macos

Because of the import of dart:mirrors via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime flutter-native on windows

Because of the import of dart:mirrors via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/utils.dartpackage:build/build.dartpackage:build/src/generate/run_post_process_builder.dartpackage:build/src/builder/post_process_builder.dartpackage:build/src/builder/builder.dartpackage:build/src/builder/build_step.dartpackage:build/src/asset/reader.dartpackage:glob/glob.dartpackage:glob/src/list_tree.dartpackage:glob/src/io.dartpackage:glob/src/io_export.dartdart:io

Package not compatible with runtime native-aot

Because of the import of dart:mirrors via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:aspen_builder/builder.dartpackage:aspen_builder/src/bundle_generator.dartpackage:aspen_builder/src/default_loaders.dartpackage:aspen_builder/src/default_loaders/css_loader.dartpackage:aspen_builder/loader.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/utils.dartpackage:build/build.dartpackage:build/src/generate/run_post_process_builder.dartpackage:build/src/builder/post_process_builder.dartpackage:build/src/builder/builder.dartpackage:build/src/builder/build_step.dartpackage:build/src/asset/reader.dartpackage:glob/glob.dartpackage:glob/src/list_tree.dartpackage:glob/src/io.dartpackage:glob/src/io_export.dartdart:io

Health issues and suggestions

Document public APIs. (-1 points)

10 out of 10 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/bundle_generator.dart. (-0.50 points)

Analysis of lib/src/bundle_generator.dart reported 1 hint:

line 63 col 28: 'displayName' is deprecated and shouldn't be used. Use getDisplayString instead.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and aspen_builder.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.8.0 <3.0.0
analyzer >=0.37.0 <0.40.0 0.39.12
aspen ^0.3.0 0.3.0+1
build ^1.2.0 1.3.0
csslib ^0.16.1 0.16.1
source_gen ^0.9.4+3 0.9.5
z85 ^0.1.0 0.1.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
args 1.6.0
async 2.4.2
charcode 1.1.3
collection 1.14.13
convert 2.1.1
crypto 2.1.5
dart_style 1.3.6
glob 1.2.0
html 0.14.0+3
js 0.6.2
logging 0.11.4
meta 1.2.1
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
pedantic ^1.9.0 1.9.1