aspen_assets 0.2.1

  • Readme
  • Changelog
  • Installing
  • 48

aspen_assets #

Access assets packed via Aspen. See the Aspen documentation for more details.

development #

0.2.0 #

  • Ensure assets are never globally loaded twice.

0.1.1 #

  • Fix a decoding bug in the CSS loader.

0.1.0 #

Initial.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aspen_assets: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aspen_assets/aspen_assets.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: web, other

Primary library: package:aspen_assets/aspen_assets.dart with components: js.

Health suggestions

Fix lib/aspen_assets.dart. (-1 points)

Analysis of lib/aspen_assets.dart reported 2 hints:

line 8 col 8: Unused import: 'dart:typed_data'.

line 12 col 7: The declaration '_Asset' isn't referenced.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and aspen_assets.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-0.82 points)

The package was last published 52 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
js ^0.6.1 0.6.1+1