app_usage 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 80

app_usage #

pub package

Install #

Add app_usage as a dependency in pubspec.yaml. For help on adding as a dependency, view the documentation.

Android #

NB: Requires API level 21 as a minimum!

You need to add the following package to the manifest namespace in AndroidManifest.xml:


as well as the following permissions to the manifest:

        tools:ignore="ProtectedPermissions" />

Below is an example of how the start of your manifest should look in the end

<manifest xmlns:android=""


Usage #

void getUsageStats() async {
    // Initialization
    AppUsage appUsage = new AppUsage();
    try {
      // Define a time interval
      DateTime endDate = new;
      DateTime startDate = DateTime(endDate.year, endDate.month,, 0, 0, 0);
      // Fetch the usage stats
      Map<String, double> usage = await appUsage.fetchUsage(startDate, endDate);
      // (Optional) Remove entries for apps with 0 usage time
      usage.removeWhere((key,val) => val == 0);
    on AppUsageException catch (exception) {

Example #

The first screen will ask for permission to view usage stats. Tap on your application. Screen 1

Tap on the 'Permit usage access' switch. Screen 2

Your application is now running, if the manifest has been corectly set up you should be presented with the following screen after tapping the refresh button. Screen 3

0.0.1 #

  • TODO: Describe initial release.


app_usage_example #

Demonstrates how to use the app_usage plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  app_usage: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:app_usage/app_usage.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/app_usage.dart.

Run flutter format to format lib/app_usage.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8